Chevrolet Nova Forum banner
481 - 500 of 503 Posts

·
Premium Member
Joined
·
87 Posts
Broke down and installed a PCV valve. Put 100 miles (50 miles each way) on her Wednesday on an 85 degree day. Temp never got above 150 degrees. I'm pleased with that, but guess I'll break down and stick a 180 thermostat in there. Right now I'm just running a thermostat shell with an electric water pump and an electric fan and aluminum radiator. I've been keeping an eye on that temp guage while breaking in this new setup. First trip out of town, now I'm confident enouth to make it to some cruise-ins this summer.
 

·
Registered
Joined
·
191 Posts
Moved it to the other side of the garage so I could get to the passenger side of the Chevelle. No I have managed to rip my shorts on the parachute on the back of the Chevelle since it is so close to the door from the house.:mad:
 

·
Registered
Joined
·
319 Posts
Well fellas. I have been driving my Nova around like crazy I love it. Not really sure if my engine has a cam in it or not it kinda has a small loping sound but eventually I'd like to turn it into a 383 Stroker. Ended up putting an Edelbrock 600 on it. Going to have my signal lights fixed and my headlights adjusted tomorrow. She runs very good but has a small miss but boy she can fly. I had her going 120 mph down the road in no time since I have a big long road near my house everyone drag races at. I will try and take a video of it driving.
 

·
Registered
Joined
·
7 Posts
Loaded my 69 on a trailer and took it to my buddy's shop for prep work, it's getting painted across the alley from his shop, should be a few weeks, but will probably be a few months.... lol. Then I bring it home and put the engine back in....
 

·
Premium Member
Joined
·
87 Posts
Popped at 5800 rpm chip in the rev limiter on the MSD so I don't get carried away now that the 5 speed has been in the car long enough for me to play a little. Cam quits pulling at 6K, so that should be OK. Changed the oil to Royal Purple high zinc content synthetic. Line lock is plumbed but not yet wired. Road trip (115 mi. ea way) this weekend to my home town for a cruise in. First long distance test of the car. My confidence is up, but I'm keeping my fingers crossed anyway.
 

·
Registered
Joined
·
44 Posts
I bought a '69 several weeks ago that has not run in at least several years. I've been trying to fix all the neglect it's suffered over the years. Took some trim off in preperation for a cheapy paint job, replaced a thermostat on the 6 cyl that looked like it had been in for the last 20 years, lol. Then went to a local forgotten junkyard that I had seen a '70 Nova hidden in the weeds. My son and I braved the 100+ temps, weeds, snakes and wasps to see what was left, if anything, on it that I could use for the '69. Turns out it has straight bumpers, the back glass trim and a trunk latch I need. Gonna wait for it to cool off, then go back and get this stuff.
 

·
Registered
Joined
·
7 Posts
Fixed a bad ground on the left brake lamp. Pulled the left front wheel to look at the brakes (the 64 is new to me ) and found a 6X6 hole someone torched in the inner fender, need to fix that before it rains.
 

·
Premium Member
Joined
·
17,539 Posts
Stripping the old '85 Impala of all speed parts getting ready to move everything over to the Nova in the future. Old 582 motor and 4L80e tranny go on stands out in the barn as I build a new blown 557 cid engine. (still in the parts collection stage so nobody hold your breath for this one)

Big Dave
 
481 - 500 of 503 Posts
Top