Chevrolet Nova Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello all,new to the site:)

My 67 has an intermittent (aren't they all) wiring problem.

When the problem pops up all rear lights won't work and the dash is dark.
Everything else is fine and this condition comes and goes:(
Fuses are good,car has stock wiring,I'm lost on electrical.

Help,

RED67
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
69NovaSS thanks for the heads up.I have an assembly manual and a service manual with the diagrams.All the obvious grounds are good,,engine block,batt to the fender,tail lights.Just hoping someone else has had the same problem.

Question; is the fuse box itself grounded? An old mechanic told me it is.

:confused: RED67
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
Thanks for the welcome Phillip.I worked on the car last night making good grounds & ck'ing for bad connections.The electric choke works better now:thumbsup:
Think I'll replace all the fuses tonight,,looks like they've been in there a long time.
One intermittent problem that came and went last night with all my poking around and test light probing is the Gen light glows bright when the transmission back up switch is hooked up:confused:
The switch is new and stock (4 speed),,it or it's wires are not grounded or shorted.I put a disconnect on it,,hook it up gen glows,,disconnect nothing.But each time no rear lights:(

TIA,WP
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
Thanks for the welcome xinloi44.

Yes, making all grounds solid and looking for "opens".

At this point the "inst-rear lamps" fuse clip has no power,,,AT ALL:confused:

So let the "tracing continue":(

Happy Easter by the way:)

RED67
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #10 ·
Cured :thumbsup:

Dash wasn't grounded and Voltage regulator was "intermitient bad" :confused: as tested in the 1967 GM service manual.

As stated on the other Nova board the dash in the '67 model grounds thru the mounting screws.Well this car has a very good paint job when restored and not all the screws where making contact:clonk: .So a little trimming with a knife and "wella":D

Now;all fuse holders are clean,all grounds are good and a new voltage regulator,,replaced a few old cracked wires,,,the dash is bright,,14.2 volts charging,,,,,,,,,,,,,and the electric choke on the Holley carb works perfect.:hurray:

Thanks to all the guys that gave advise:)

RED67
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top