Chevrolet Nova Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey Guys,

I have an original/low mileage '64 Nova with the 230 cubic inch straight 6. The car is in excellent condition, but I'm a bit of a novice when it comes to diagnosing/fixing issues on my own - Oil changes are about the current extent of my knowledge. I have a reputable mechanic but would prefer to learn as I go and also have an understanding of any problems before taking it in to the shop, if necessary.

Anyways, I was pulling out of Home Depot last weekend and a guy walking by mentions that it sounds like I might need a valve job. I suppose I can hear a slight pinging/knocking, but I'm not sure what exactly the issue is or how soon it should be addressed. I posted a short video of the engine running at normal operating temps in hopes you might be able to chime in. If you could take a minute to check it out and share your thoughts I'd really appreciate it.

Here's the video link: https://youtu.be/sVdDgj0zjZE

What do you think the issue is (if any)?

Here's a few pictures of the car - Have a great holiday weekend! :beers:
 

Attachments

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
My speakers aren't the greatest, but kinda sounds like you have some loose rocker arms??..
Thanks, Art. I looked at a couple other videos online and that definitely could be the issue. Sounds very similar. If that's the case, it seems like a relatively easy fix. I'll take a look when I have time this week and update.
 
1 - 3 of 3 Posts
Top